分享到:
当前位置主页 > 知识学堂 > 股票书籍 > 亲,看到好文章一点要记得分享到空间哦!
 股票  钱程无忧  顶牛股  顶牛贷  股票配资  股票e360

追击反转指标 源码(大智慧、通达信)

发布时间:2018-02-12 来源:mrchy.com 编辑:顶牛股

追击反转指标 源码(大智慧、通达信)

大家元旦快乐。最近追击的一个帖子被大家推荐为精华帖,有了很多朋友,为了感谢大家的厚爱,现贡献给你们一个完全加密的原版指标---追击反转,希望朋友们喜欢,但是也别忘记推荐吆(笑话)。发的是源码文件,有大智慧的,也有通达信的,还有通用的选股公式。可以根据自己的股软选择性复制

追击反转指标 源码(大智慧、通达信)

追击反转指标 源码(大智慧、通达信)

追击反转指标 源码(大智慧、通达信)

{原指标源码,大智慧有DDX数据的直接复制可用} AA1:=FILTER(L=LLV(L,13),8); AA2:=if(LLV(L,3)=LLV(L,13) AND C<REF((H+L)/2,1),MAX(REF(LLV(L,12),BARSLAST(AA1)+1)-L,0),0); AA3:=EMA(AA2,3)*3; AA4:=SUMBARS(AA3>0,21); AA5:=SUM(AA3,AA4)/21; AA6:=REF(AA3,1)=HHV(AA3,3) AND REF(AA3,1)>AA5*3 AND COUNT(C/REF(C,1)<0.9025,8)=0 and ISUP and LLV(L,3)/HHV(H,18)<0.88; AA7:=(COUNT("DDX.DDX">0,5)>0 OR NOT("DDX.DDX1"<"DDX.DDX2" AND "DDX.DDX2"<"DDX.DDX3")) AND COUNT("DDX.DDX">REF("DDX.DDX",1),10)>=6; 反转:=AA6 AND AA7 ; stickline(close,0,AA3,8,1),coloryellow; stickline(反转,0,AA3,8,0),colorred; {以下是大智慧改良的不用DDX数据的源码} DRAWGBKLAST(CLOSE>0,STRIP(RGB(47,79,79),RGB(0,0,0),0)); AA:=VOL/((H-L)*2-ABS(C-O)); 买量:=AA*(H-L); 卖量:=0-AA*((H-C)+(O-L)); 进出量:=(买量+卖量)>0; AA1:=FILTER(L=LLV(L,13),8); AA2:=if(LLV(L,3)=LLV(L,13) AND C<REF((H+L)/2,1),MAX(REF(LLV(L,12),BARSLAST(AA1)+1)-L,0),0); AA3:=EMA(AA2,3)*3; AA4:=SUMBARS(AA3>0,21); AA5:=SUM(AA3,AA4)/21; AA6:=REF(AA3,1)=HHV(AA3,3) AND REF(AA3,1)>AA5*3 AND COUNT(C/REF(C,1)<0.9025,8)=0 and ISUP and LLV(L,3)/HHV(H,18)<0.88; {AA7:=(COUNT("DDX.DDX">0,5)>0 OR NOT("DDX.DDX1"<"DDX.DDX2" AND "DDX.DDX2"<"DDX.DDX3")) AND COUNT("DDX.DDX">REF("DDX.DDX",1),10)>=6;} 均线条件:=EMA(C,5)>=REF(EMA(C,5),1) ; {增加这个条件过滤掉那些股票价格继续下行,而出现信号} 反转:=FILTER(AA6 AND 进出量 AND 均线条件,3); {增加了过滤信号语句,减少重复信号} stickline(close,0,AA3,8,1),coloryellow; stickline(反转,0,AA3,8,0),colorred; {以下是通达信公式源码,通达信不能用DDX数据的} AA:=VOL/((H-L)*2-ABS(C-O)); 买量:=AA*(H-L); 卖量:=0-AA*((H-C)+(O-L)); 进出量:=(买量+卖量)>0; AA1:=FILTER(L=LLV(L,13),8); AA2:=IF(LLV(L,3)=LLV(L,13) AND C<REF((H+L)/2,1),MAX(REF(LLV(L,12),BARSLAST(AA1)+1)-L,0),0); AA3:=EMA(AA2,3)*3; AA4:=SUMBARS(AA3>0,21); AA5:=SUM(AA3,AA4)/21; AA6:=REF(AA3,1)=HHV(AA3,3) AND REF(AA3,1)>AA5*3 AND COUNT(C/REF(C,1)<0.9025,8)=0 AND LLV(L,3)/HHV(H,18)<0.88; 均线条件:=EMA(C,5)>=REF(EMA(C,5),1) ; {增加这个条件过滤掉那些股票价格继续下行,而出现信号} 反转:=FILTER(AA6 AND 进出量 AND 均线条件,3); {增加了过滤信号语句,减少重复信号} STICKLINE(CLOSE,0,AA3,2.7,1),COLORYELLOW; STICKLINE(反转,0,AA3,2.7,0),COLORRED; {以下是选股公式,大智慧和通达信都能用} AA:=VOL/((H-L)*2-ABS(C-O)); 买量:=AA*(H-L); 卖量:=0-AA*((H-C)+(O-L)); 进出量:=(买量+卖量)>0; AA1:=FILTER(L=LLV(L,13),8); AA2:=IF(LLV(L,3)=LLV(L,13) AND C<REF((H+L)/2,1),MAX(REF(LLV(L,12),BARSLAST(AA1)+1)-L,0),0); AA3:=EMA(AA2,3)*3; AA4:=SUMBARS(AA3>0,21); AA5:=SUM(AA3,AA4)/21; AA6:=REF(AA3,1)=HHV(AA3,3) AND REF(AA3,1)>AA5*3 AND COUNT(C/REF(C,1)<0.9025,8)=0 AND LLV(L,3)/HHV(H,18)<0.88; 均线条件:=EMA(C,5)>=REF(EMA(C,5),1) ; 反转:=AA6 AND 进出量 AND 均线条件; XG:FILTER(反转,3); {说明:公式均通过测试,朋友们可以自己在根据历史K线检验,任何公式都不可能反应所有买卖点。信号出现离50日均线越近越好}



本文网址分享:http://www.mrchy.com/a/zhishixuetang/gupiaoshuji/2018/0212/7715.html

推荐图文

顶牛股网 www.mrchy.com
Copyright @ 2010-2018 mrchy.com 皖ICP备11016751号-1 All Right Reserved
免责声明:本站所发表的文章版权归作者所有,若转载或者抄袭他人作品,带来的一切后果与本站无关。
若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!