当前位置主页 > 知识学堂 > 江恩理论 > 亲,看到好文章一点要记得分享到空间哦!
 股票  股票配资  顶牛股  股票配资 0  钱程无忧   股 0

大智慧趋势划线指标公式

发布时间:2019-03-31 来源:mrchy.com 编辑:顶牛股

大智慧趋势划线指标公式:含有未来函数

input: N(5,1,100);
 {DRAWGBKLAST(CLOSE>0,STRIP(RGB(95,95,95),RGB(0,0,0),0));}
 主筹估算:=EMA(WINNER(c)*70,3);
 散筹估算:=EMA((WINNER((c)*1.1)-WINNER((c)*0.9))*70,3);
筹码锁定:=散筹估算-主筹估算 ;
 动态底部:=EMA(IF(L<= LLV(l,60),SMA(ABS(L-REF(L,1)),60,1)/SMA(MAX(L-REF(l,1),0),99,1),0)*5,3);
 涨:=CROSS(主筹估算,筹码锁定);
 强:=CROSS(主筹估算,散筹估算);
 STICKLINE(涨,O,C,8,0),COLORYELLOW;
 STICKLINE(涨,O,H,0,0),COLORYELLOW;
 STICKLINE(涨,L,C,0,0),COLORYELLOW;
 STICKLINE(强, O,C,8,0),colormagenta;
 STICKLINE(强,O,H,0,0),colormagenta;
 STICKLINE(强,L,C,0,0),colormagenta;
 A1:=ref(h,N)=hhv(h,2*N+1);
 B1:=filter(A1,N);
 C1:=backset(B1,N+1);
 D1:=filter(C1,n);{高点}
 A2:=ref(l,N)=llv(l,2*N+1);
 B2:=filter(A2,N);
 C2:=backset(B2,N+1);
 D2:=filter(C2,N);{低点}
 E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2; E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍}
 H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1;
 L1:=(D2 AND not(D1 AND E1=E2);
 X1:=ref(barslast(H1),1)+1; F1:=backset(H1 AND count(L1,X1)>0,llvbars
 (if(L1,l,10000),X1));
 G1:=F1>ref(F1,1); I1:=backset(G1,2); LD:=I1>ref(I1,1);{过滤后低点}
 L2:=LD OR barstatus=2 OR barscount(c)=1;
 X2:=ref(barslast(L2),1)+1; F2:=backset(L2 AND count(H2,X2)>0,hhvbars
 (if(H2,h,0),X2));
 G2:=F2>ref(F2,1); I2:=backset(G2,2); HD:=I2>ref(I2,1);{过滤后高点}
 R1:=backset(barstatus=2,barslast(HD)+1); S1:=R1>ref(R1,1); {前一高}
 T1:=backset(barstatus=2,barslast(LD)+1); U1:=T1>ref(T1,1); {前一低}
 R2:=backset(S1,ref(barslast(HD),1)+2); S2:=R2>ref(R2,1); {前二高}
 T2:=backset(U1,ref(barslast(LD),1)+2); U2:=T2>ref(T2,1); {前二低}
 T3:=backset(U2,ref(barslast(LD),1)+2); U3:=T3>ref(T3,1); {前三低}
 T4:=backset(U3,ref(barslast(LD),1)+2); U4:=T4>ref(T4,1); {前四低}
 R3:=backset(S2,ref(barslast(HD),1)+2); S3:=R3>ref(R3,1); {前三高}
 R4:=backset(S3,ref(barslast(HD),1)+2); S4:=R4>ref(R4,1); {前四高}
 短期压力:drawline(S2,h,S1,h,1),Colorred;
 短期支撑:drawline(U2,l,U1,l,1),Colorgreen;
 中期压力:drawline(S3,h,S2,h,1),Coloryellow;
 中期支撑:drawline(U3,l,U2,l,0),Colorgreen;
 长期压力:drawline(S4,h,S3,h,1),COLORwhite;
 长期支撑:drawline(U4,l,U3,l,0),Colorgreen;
 DRAWICON(S1,H*1.01,2);
 DRAWICON(S2,H*1.01,2);
 DRAWICON(S3,H*1.01,2);
 DRAWICON(S4,H*1.01,2);
 DRAWICON(U1,L*0.99,1);
 DRAWICON(U2,L*0.99,1);
 DRAWICON(U3,L*0.99,1);
 DRAWICON(U4,L*0.99,1);
止损价:=REF(c,1)*0.95;
 DRAWTEXT(c>0 and BARSTATUS=2,h*1.03,' 止损价:'+NUMTOSTRN(止损价,2)),ALIGN0,colorffffff;

大智慧趋势划线指标公式实例图解:

大智慧趋势划线指标公式

大智慧趋势划线指标公式

,炒股配资,配资开户 本文网址分享:http://www.mrchy.com/a/zhishixuetang/hongenlilun/2019/0331/111980.html
推荐图文
相关文章
顶牛股 www.mrchy.com
Copyright @ 2010-2018 mrchy.com 皖ICP备11016751号-1 All Right Reserved
免责声明:顶牛股股票配资所发表的文章版权归作者所有,若转载或者抄袭他人作品,带来的一切后果与本站无关。
若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!